Route redistribution (RR) has become an integral part of IP network design as the result of a growing need for disseminating certain routes across routing protocol boundaries. While RR is widely used and resembles BGP in several nontrivial aspects, surprisingly, its safety has not been systematically studied by the networking community. This article presents the analytical model for understanding the effect of RR on network wide routing dynamics and evaluating the safety of a specific RR configuration.

We first illustrate how easily inaccurate configurations of RR may cause severe routing instabilities, including route oscillations and persistent routing loops. At the same time, general observations regarding the root causes of these instabilities are provided. We then introduce a formal model based on general observations to represent and study the safety of route redistribution. Using the model, we prove that an RR configuration allows you to get desired routes from another routing protocol. Given this complexity, we present a sufficient condition, which can be checked with different scenarios using different routing protocols

Recent studies show that some enterprise networks rival carrier networks in terms of scale and complexity of routing design. One may even argue that because of a more dynamic business environment fuelled by acquisitions and mergers, large enterprise networks may be more difficult to control and manage than carrier networks.

One source of this difficulty stems from the fact that the routing structure of a large enterprise network typically consists of multiple domains or routing instances. Routing instances form for many reasons. Company acquisitions, departments administered by different teams, and multi-vendor equipment’s may lead to such situations. Alternatively, network administrators may intentionally create separate routing instances to filter routes, limit reachability and enforce policies.

Routers within one routing instance typically run the same routing protocol to fully share reachability information and they by default do not exchange routing information with routers in other routing instances.

Consider the network depicted in Figure 1. It consists of two routing instances. Routers in the RIP instance do not have visibility of the addresses and subnet prefixes in the OSPF instance and vice versa. To allow the exchange of routing information between different routing instances, router vendors have introduced a feature called route
redistribution
. Route redistribution is a configuration.

As such, router vendors introduced RR to address a need from network operations. We recently looked at the configurations of some large university campus networks and found that RR is indeed widely used. However, contrary to traditional routing protocols, there is no standard or RFC formally defining the functionality of RR. Significant efforts are usually associated with the design and analysis of a routing protocol to ensure its correctness and stability but the specification of RR did not receive as much attention. Consequently, RR is often misconfigured, leading to sub-optimal routing and even severe instabilities such as route oscillations and persistent routing loops.


A router running multiple routing processes does not by default redistribute routes among these processes. Route redistribution must be explicitly configured. In Cisco, route-map allows network administrators to filter the routes, prioritize the received announcements (by assigning different AD values) and modify the attributes of the redistributed routes. Below I provide an example of a Cisco configuration redistributing routes from a RIP process into an OSPF one. The route-map statements filter the route and modify the attributes of the redistributed routes.

I think now you guys want some scenarios on it. When I was learning Cisco technology, I loved to get involved with practical scenarios. Let’s look at a scenario where three routers are logically connected and RIPv2 is running between R1-R2 and OSPF with Area0 configured between R2-3 but R1 is not getting routes from R3 vice versa (coz R1/R3 running different Routing Protocol).

To get R1-R3 communication, we need to do route redistribution, but first, we have to configure all loopback interfaces on the R1 & R3 routers as shown in the diagram.

Configure the serial interfaces with the IP addresses, bring them up, and set a DCE clock rate where appropriate.

R1 Configuration:

R1(config)# interface Loopback0
R1(config-if)# ip address 1.1.1.1 255.255.255.255
R1(config)# interface Loopback1
R1(config-if)# ip address 11.11.11.11 255.255.255.255
R1(config)# interface S1/0
R1(config-if)# ip address 12.1.1.1 255.255.255.252
R1(config-if)# no shut R1(config-if)# no shut

R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# network 1.1.1.1
R1(config-router)# network 11.11.11.11
R1(config-router)# network 12.1.1.0
R1(config-router)# no auto-summary

R2 Configuration:

R2(config)# interface Loopback0
R2(config-if)# ip address 2.2.2.2 255.255.255.255
R2(config)# interface S1/0
R2(config-if)# ip address 12.1.1.2 255.255.255.252
R2(config-if)# no shut
R2(config)# interface S1/1
R2(config-if)# ip address 23.1.1.1 255.255.255.252
R2(config-if)# no shut

R2(config)# router rip
R2(config-router)# version 2
R2(config-router)# network 2.2.2.2
R2(config-router)# network 12.1.1.0
R2(config-router)# network 23.1.1.0
R2(config-router)# redistribute ospf 1 metric 10 /* OSPF redistribution under RIP
R2(config-router)# no auto-summary
R2(config)# router ospf 1
R2(config-router)# network 2.2.2.2 0.0.0.0 area 0
R2(config-router)# network 12.1.1.2 0.0.0.0 area 0
R2(config-router)# network 23.1.1.1 0.0.0.0 area 0
R2(config-router)# redistribute rip subnets /* RIP redistribution under OSPF process

R3 Configuration:

R3(config)# interface Loopback0
R3(config-if)# ip address 3.3.3.3 255.255.255.255
R3(config)# interface Loopback1
R3(config-if)# ip address 33.33.33.33 255.255.255.255
R3(config)# interface S1/1
R3(config-if)# ip address 23.1.1.2 255.255.255.252
R3(config-if)# no shut

R3(config)# router ospf 1
R3(config-router)# network 3.3.3.3 0.0.0.0 area 0
R3(config-router)# network 33.33.33.33 0.0.0.0 area 0
R3(config-router)# network 23.1.1.2 0.0.0.0 area 0

If we don’t configure redistribution, we will not get OSPF routes on R1 (where RIP is configured) as below in Fig 2.1 and same for R3, since R3’s routing table does not contain R1/RIP routes as shown on Fig 2.2.

But after configuring mutual redistribution (on R2 , because both routing protocols are running on it) for both routing protocols with their respective metric values:

R2(config)# router rip

R2(config-router)# redistribute ospf 1 metric 10 /* OSPF redistribution under RIP

R2(config)# router ospf 1

R2(config-router)# redistribute rip subnets /* RIP redistribution under OSPF process

After we configure mutual redistribution for RIP and OSPF, we get the desired routes, meaning now we can see OSPF routes (R3 Loopbacks) on R1 as shown in Fig. 2.3:

And we are also getting RIP routes as O E2 in R3 routing table as shown in Fig 2.4:

We have gone through all the conceptual knowledge regarding Route Redistribution for a CCNA candidate. You will learn how to apply routes/maps/prefix lists/filter list while configuring redistribution once you go for CCNP, but one thing you should always keep in mind is that practice makes perfect, so to become best with redistribution, you need to try it with different routing protocols like those shown in Fig. 3 and 3.1. Also for static routing, you need to configure and redistribute static subnets under


OSPF process, and to redistribute static route in to RIP you need to write redistribute static metric 10. If you find any difficulty then you can write me at the comments section; I am eagerly waiting for you comments. Thanks for your time and consideration.

References

  1. Cisco OSPF Route Redistribution By William R. Parkhurst.
  2. CCNP ROUTE Certification Guide: Basic IGP Redistribution By Wendell Odom, Ciscopress.com
  3. Guide to Cisco Certified Network Associate by Richard Deal.
  4. Cisco Certified Network Professional-Route by Wendel Odom, Ciscopress.com
  5. CCNP- Route Quick reference by Denis Donohou, Ciscopress.com
  6. Cisco Certified Internetwork Expert Quick reference by Brad Ellis, Ciscopress.com