In this article, we will discuss EIGRP named mode. If you are studying for CCNP, then you will run into this at some point.

There are two ways of configuring EIGRP. The classic way, called EIGRP AS mode, is the most common. Using this mode, commands related to EIGRP are placed in different hierarchies of the router configuration. For instance, the EIGRP hello and holdtime intervals are placed under interfaces whose subnet is advertised in EIGRP. The networks advertised in EIGRP are placed under EIGRP router configuration, but it’s not that easy to follow up an EIGRP configuration. You need to jump back and forth through the configuration to get all the pieces.

CCNP Training – Resources (Intense)

The second method of configuring EIGRP is called named EIGRP. It was developed to consolidate the hierarchy where the entire EIGRP configuration is done. Basically, you have only one place where you need to look to check the configuration.

Named EIGRP is more about how to configure EIGRP. Nothing has changed in the operation of the protocol. But a few examples should clarify this.

We will use this topology:

This is how you enter the named EIGRP configuration:

R1(config)#router eigrp ?
 Autonomous System
WORD EIGRP Virtual-Instance Name

R1(config)#router eigrp

As you can see, it’s pretty similar to the old way of configuring EIGRP. Once you provide a name, then the device knows that you want to use named EIGRP.

R1(config)#router eigrp NAMED_EIGRP
R1(config-router)#?
Router configuration commands:
address-family Enter Address Family command mode
default Set a command to its defaults
exit Exit from routing protocol configuration mode
no Negate a command or set its defaults
service-family Enter Service Family command mode
shutdown Shutdown this instance of EIGRP

R1(config-router)#

Once you enter the named EIGRP configuration hierarchy, you will not see too many options. However, the one that’s most interesting is “address-family”. From here you can select whether you’ll use EIGRP for IPv4 or IPv6:

R1(config-router)#address-family ?
ipv4 Address family IPv4
ipv6 Address family IPv6

Going even further, you have the options to configure multiple families for IPv4, like unicast or multicast. You can enter the VRF where EIGRP will run if you want to as well. We will see this later:

R1(config-router)#address-family ipv4 ?
autonomous-system Specify Address-Family Autonomous System Number
multicast Address Family Multicast
unicast Address Family Unicast
vrf Specify a specific virtual routing/forwarding instance

Let’s be as specific as possible and select the unicast address family and configure our AS:

R1(config-router)#address-family ipv4 unicast autonomous-system 120

Once you enter the address-family hierarchy, you will see options that you would see under EIGRP routing protocol hierarchy in the old configuration format:

R1(config-router-af)#?
Address Family configuration commands:
af-interface Enter Address Family interface configuration
default Set a command to its defaults
eigrp EIGRP Address Family specific commands
exit-address-family Exit Address Family configuration mode
help Description of the interactive help system
maximum-prefix Maximum number of prefixes acceptable in aggregate
metric Modify metrics and parameters for address advertisement
neighbor Specify an IPv4 neighbor router
network Enable routing on an IP network
no Negate a command or set its defaults
shutdown Shutdown address family
timers Adjust peering based timers
topology Topology configuration mode

There are a few interesting commands in the above output that we will discuss in a few moments. One of them is “af-interface”. Here you configure interface EIGRP specific parameters:

R1(config-router-af-interface)#?
Address Family Interfaces configuration commands:
authentication authentication subcommands
bandwidth-percent Set percentage of bandwidth percentage limit
bfd Enable Bidirectional Forwarding Detection
dampening-change Percent interface metric must change to cause update
dampening-interval Time in seconds to check interface metrics
default Set a command to its defaults
exit-af-interface Exit from Address Family Interface configuration mode
hello-interval Configures hello interval
hold-time Configures hold time
next-hop-self Configures EIGRP next-hop-self
no Negate a command or set its defaults
passive-interface Suppress address updates on an interface
shutdown Disable Address-Family on interface
split-horizon Perform split horizon
summary-address Perform address summarization

R1(config-router-af-interface)#

Here you can configure the EIGRP authentication, like EIGRP intervals for instance. Let’s configure the authentication:

R1(config-router-af-interface)#authentication ?
key-chain key-chain
mode authentication mode

R1(config-router-af-interface)#authentication key-chain EIGRP
R1(config-router-af-interface)#authentication mode md5
R1(config-router-af-interface)#end
R1#

Let’s configure the timers as well:

R1(config-router-af-interface)#hello-interval 3
R1(config-router-af-interface)#hold-time 9
R1(config-router-af)#end
R1#

Let’s go back to “address-family” hierarchy and configure EIGRP to run on the interface towards R2 by using the “network” command:

R1(config-router-af)#?
Address Family configuration commands:
af-interface Enter Address Family interface configuration
default Set a command to its defaults
eigrp EIGRP Address Family specific commands
exit-address-family Exit Address Family configuration mode
help Description of the interactive help system
maximum-prefix Maximum number of prefixes acceptable in aggregate
metric Modify metrics and parameters for address advertisement
neighbor Specify an IPv4 neighbor router
network Enable routing on an IP network
no Negate a command or set its defaults
shutdown Shutdown address family
timers Adjust peering based timers
topology Topology configuration mode

R1(config-router-af)#network ?
A.B.C.D Network number

R1(config-router-af)#network 1.1.1.1 0.0.0.0
R1(config-router-af)#net 10.10.12.1 0.0.0.0
R1(config-router-af)#

After this, the EIGRP adjacency between R1 and R2 is up:

*May 22 06:34:54.503: %DUAL-5-NBRCHANGE: EIGRP-IPv4 120: Neighbor 10.10.12.2 (FastEthernet0/0) is up: new adjacency

One other interesting command under “address-family” hierarchy is “topology”. From here you can configure specific EIGRP parameters like default route origination, K values and load balancing:

R1(config-router-af-topology)#?
Address Family Topology configuration commands:
auto-summary Enable automatic network number summarization
default Set a command to its defaults
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter entries in eigrp updates
eigrp EIGRP specific commands
exit-af-topology Exit from Address Family Topology configuration mode
maximum-paths Forward packets over multiple paths
metric Modify metrics and parameters for advertisement
no Negate a command or set its defaults
offset-list Add or subtract offset from EIGRP metrics
redistribute Redistribute IPv4 routes from another routing protocol
snmp Modify snmp parameters
summary-metric Specify summary to apply metric/filtering
timers Adjust topology specific timers
traffic-share How to compute traffic share over alternate paths
variance Control load balancing variance

R1(config-router-af-topology)#

We will change the parameters that define on how many paths EIGRP can do load-balancing using the “maximum-paths” command. I did the same on R2:

R1(config-router-af-topology)#maximum-paths ?
 Number of paths

R1(config-router-af-topology)#maximum-paths 16
R1(config-router-af-topology)#

Now, let’s compare the configuration from R1, which uses named EIGRP, with the one from R2, which uses the old way of configuring EIGRP. This is from R1:

router eigrp NAMED_EIGRP
!
address-family ipv4 unicast autonomous-system 120
!
af-interface FastEthernet0/0
authentication mode md5
authentication key-chain EIGRP
hello-interval 3
hold-time 9
exit-af-interface
!
topology base
maximum-paths 16
exit-af-topology
network 1.1.1.1 0.0.0.0
network 10.10.12.1 0.0.0.0
exit-address-family
!

And this is from R2. As you can see, the equivalent configuration is spread among different configuration hierarchies:

interface FastEthernet0/0
ip address 10.10.12.2 255.255.255.0
ip hello-interval eigrp 120 3
ip hold-time eigrp 120 9
ip authentication mode eigrp 120 md5
ip authentication key-chain eigrp 120 EIGRP
duplex auto
speed auto
!
router eigrp 120
network 1.1.1.2 0.0.0.0
network 10.10.12.2 0.0.0.0
maximum-paths 16
no auto-summary
!

And the EIGRP routes are in R1’s routing table:

R1#show ip route eigrp | b Gateway
Gateway of last resort is not set

1.0.0.0/32 is subnetted, 2 subnets
D 1.1.1.2 [90/2662400] via 10.10.12.2, 00:41:38, FastEthernet0/0
R1#

And this was the configuration of EIGRP for IPv4 between R1 and R2.

Now we will configure EIGRP for IPv6 between R1 and R3. On the interfaces between them, IPv6 addresses are configured and IPv6 routing is already enabled. These actions have nothing to do with EIGRP for IPv6 and they are prerequisites for a router to forward IPv6 traffic. Actually, we might not need to configure IPv6 addresses because EIGRP packets are sourced from the link-local IPv6 addresses that are automatically configured once you enable IPv6 on the interface using “IPv6 enable”. But to keep things consistent, we will configure IPv6 addresses.

The only thing that we need to do is to enable address-family for IPv6 under named EIGRP configuration:

R1(config)#router eigrp NAMED_EIGRP
R1(config-router)#address-family ipv6 unicast autonomous-system 130
*May 22 08:54:15.183: %DUAL-5-NBRCHANGE: EIGRP-IPv6 130: Neighbor FE80::C804:D9FF:FE7D:0 (FastEthernet1/0) is up: new adjacency
R1(config-router-af)#end
R1#

So this would be the whole configuration on R1 regarding EIGRP for IPv6:

router eigrp NAMED_EIGRP
!
address-family ipv6 unicast autonomous-system 130
!
topology base
exit-af-topology
exit-address-family
!

Whereas the configuration on R3 involves enabling EIGRP for IPv6 under the interface that should be part of the routing protocol:

interface Loopback0
ip address 1.1.1.3 255.255.255.255
ipv6 address 2001:1:1:1::3/128
ipv6 enable
ipv6 eigrp 130
!
interface FastEthernet0/0
ip address 10.10.13.3 255.255.255.0
duplex half
ipv6 address 2001:1:2:3::3/64
ipv6 enable
ipv6 eigrp 130
!
ipv6 router eigrp 130
!

The routes are exchanged for IPv6 through EIGRP:

R1#show ipv route eigrp | b 2001
D 2001:1:1:1::3/128 [90/2662400]
via FE80::C804:D9FF:FE7D:0, FastEthernet1/1
R1#

The last option in configuring EIGRP is to configure it in a VRF. Again, you will need to set up the right address-family. In out topology, R4 has already been configured using the old way of configuring EIGRP and it is not part of VRF.

On the other hand, on R1, the interface F1/1 is part of VRF VRF_140.

This is the configuration on R1:

router eigrp NAMED_EIGRP
!
address-family ipv4 unicast vrf VRF_140 autonomous-system 140
!
topology base
exit-af-topology
network 1.1.1.1 0.0.0.0
network 10.10.14.1 0.0.0.0
exit-address-family
!

As you can see, the configuration is almost identical to the one from the initial IPv4 address-family, except now the routes will be placed in a VRF. There is a specific configuration that needs to be done to configure the VRF and to place the interfaces in the VRF:

vrf definition VRF_140
rd 140:140
!
address-family ipv4
exit-address-family
!
interface FastEthernet1/1
vrf forwarding VRF_140
ip address 10.10.14.1 255.255.255.0
duplex auto
speed auto
!

Once this is configured, you can see that the EIGRP adjacency was established for the VRF and that the routes are placed in it:

R1#show ip eigrp vrf VRF_140 neighbors
EIGRP-IPv4 VR(NAMED_EIGRP) Address-Family Neighbors for AS(140)
VRF(VRF_140)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.10.14.4 Fa1/1 12 00:06:46 16 100 0 2
R1#show ip route vrf VRF_140

Routing Table: VRF_140
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.4 [90/2662400] via 10.10.14.4, 00:07:08, FastEthernet1/1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.14.0/24 is directly connected, FastEthernet1/1
L 10.10.14.1/32 is directly connected, FastEthernet1/1
R1#

And that’s it about named EIGRP. By reaching this point of the article, you now will have a fair idea of what people talk about when they mention named EIGRP. Also, you now know how to configure EIGRP for IPv4, IPv6 and for VRF using the named EIGRP method.

References:

  1. CCNP Routing and Switching Official Cert Guide – Kevin Wallace
  2. EIGRP Classic to Named Mode Conversion