This is Video #2 of our MPLS Traffic Engineering series, which is designed to help viewers gain a basic understanding of MPLS Traffic Engineering and how to configure TE tunnels in Cisco routers.

In this video, we will work on a lab that demonstrates basic configuration of an MPLS TE Tunnel.

References:

http://www.cisco.com/c/en/us/td/docs/ios/12_0s/feature/guide/TE_1208S.html

http://www.cisco.com/c/en/us/support/docs/multiprotocol-label-switching-mpls/mpls/13731-mpls-te-ospf.html

http://www.cisco.com/c/dam/en/us/products/collateral/ios-nx-os-software/multiprotocol-label-switching-traffic-engineering/prod_presentation0900aecd80312824.pdf

Configuration:

Midpoint/ Tail-end Global and Interface

ip cef {distributed}
mpls traffic-eng tunnels
!
interface GigabitEthernet0/0
   mpls traffic-eng tunnels
   ip rsvp bandwidth 

Midpoint/ Tail-end OSPF

router ospf 
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng area 

Midpoint/ Tail-end IS-IS

router isis 
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-{1,2}
  metric-style wide

Head-end Global and Interface

ip cef {distributed}
mpls traffic-eng tunnels
!
interface GigabitEthernet0/0
   mpls traffic-eng tunnels
   ip rsvp bandwidth 

Head-end OSPF

router ospf 
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng area 

Head-end IS-IS

router isis 
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-{1,2}
  metric-style wide

Head-end MPLS TE Tunnel

interface Tunnel0
  ip unnumbered Loopback0 
  tunnel mode mpls traffic-eng
  tunnel source Loopback0
  tunnel destination 
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng path-option 10 dynamic